Bug #346

Compilation Error

Added by George Kopanas over 2 years ago. Updated over 2 years ago.

Status:NewStart date:12/01/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Hello,

I am following the steps to install mitsuba, I am in Fedora 21, I get a big amount of errors, they start when compiling the "mtsgui/aboutdlg.cpp"
and are all similar to these

build/release/mtsgui/aboutdlg.cpp: In constructor ‘AboutDialog::AboutDialog(QWidget*)’:
build/release/mtsgui/aboutdlg.cpp:25:13: error: invalid use of incomplete type ‘class Ui::AboutDialog’
ui(new Ui::AboutDialog) {

I am attaching a text with all errors and the terminal output plus config.log

If someone has some insight please help.

George
^

config.log (15.7 KB) George Kopanas, 12/01/2015 12:51 pm

terminal_out.txt Magnifier (5.92 KB) George Kopanas, 12/01/2015 12:53 pm

History

#1 Updated by Cédric Devivier over 2 years ago

Hi,

If your goal is only to ray trace some scenes, you can do without the GUI.

To do so, you can do either one of the following options:
  • uninstall all qt4 packages which may brake some dependencies
  • edit the file build/Sconscript.configure and change the following line:
    env = Environment(options=vars, ENV = os.environ, tools=['default', 'qt4', 'icl12'], toolpath=['#data/scons'])
    by
    env = Environment(options=vars, ENV = os.environ, tools=['default', 'qt413', 'icl12'], toolpath=['#data/scons'])

Hope it helps,
Cédric

Also available in: Atom PDF